WSS/SharePoint Http 404 Connection Close Error

WSS/SharePoint Http 404 Connection Close Error

This afternoon I have noticed that a few of our WSS sites have stopped working, when trying to access them we got the following error:

HTTP/1.1 404 Connection: close Date: Tue, 26 Aug 2008 01:40:55 GMT Server: Microsoft-IIS/6.0 MicrosoftSharePointTeamServices: 12.0.0.6039 X-Powered-By: ASP.NET

It turns out this error is almost as common as the ‘Object Reference not set to an Instance of an object’ error. My research proved to be fruitless so I did some poking around on the server itself.

It turns out that this error can appear when a site collection has been created with no top level site.

e.g. http://yourserver:1000/sites/test

In the example above, a site collection has been created under ‘sites’ with no top level site, for the above to work correctly there would need to be a site collection here: http://yourserver:1000/

Sure enough the site in question had no top level site. Once I had created a blank one, the site was accessible again. I know for a fact that the site used to work so I am not sure that this error was introduced in a SharePoint/Windows update that has recently been released.

So keep your eye out :-)

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">