SharePoint Administration

Retrieving values of Managed Properties in SharePoint 2013 Search REST API

Having just spent the best part of a day trying to figure out how to query values of Managed Properties within a SharePoint 2013 App using the new Search REST API, I thought I would share with you how it’s done. There is a real lack of decent MSDN documentation…

Enabling SharePoint 2013 ‘Apps’

After installing and configuring SharePoint 2013, if you try to visit the SharePoint App Store you will notice a warning message ‘Sorry, apps are turned off. If you know who runs the server, tell them to enable apps.”. Well lucky for us, we run this server so it’s time to…

SharePoint 2013 Configuration Wizard Error ‘maxdegree of parellelism’

When trying to configure SharePoint 2013 on SQL Server 2012 I got the following error – ‘This SQL Server Instance does not have the required maxdegree of parellism setting of 1’ It turns out this is a simple fix, just run the following SQL script to set the ‘maxdegree of…

GrantAccessToProcessIdentity – A very handy SharePoint PowerShell command!

I thought I’d do a write up on this one as its something that always catches me out every time I’m configuring a SharePoint farm. If you are setting up services e.g. Excel Services or Office Web Apps then it’s likely you will need to grant the service account running…

SharePoint 2003 site in 2010 –‘Error on page’ when trying to add web parts

We recently came across this issue when migrating some SharePoint Portal Server 2003 sites to SharePoint 2010 for a client. The UI of the site had not been upgraded and was still showing the 2003 look and feel. When attempting to add web parts to the page using the ‘Edit…

Opening InfoPath Browser Forms as Anonymous Users -UnauthorizedAccessException

I came across this issue yesterday when trying to work out why an InfoPath form that I had published wasn’t working. The Site Collection that I deployed the form to had been configured for Anonymous access. When trying to open the form in the browser it failed to load –…

‘The content WebService is not running in this server’

  I had a problem this morning with a 3 server SharePoint farm (DB, APP and WFE) where Feature files, Assemblies and pretty much any file contained in a WSP package was not getting deployed to the APP server. I first spotted this issue when deploying a WSP file containing…

SharePoint Doc Lib ‘Open with Windows Explorer’ not working in Server 2008 R2

  I had this problem today in my dev VM, when clicking the ‘Open with Windows Explorer’ link on a doc lib nothing happened. It seems to get it working in Server 2008 R2 you need to install the ‘Desktop Experience’ feature – once installed and rebooted it works like…

Accessing a SharePoint site by IP Address – Alternate Access Mappings!

  If you want to access a SharePoint site remotely be it WSS, 2007 or 2010 by using the IP address then you will need to configure the Alternate Access Mappings correctly. This caught me out today when trying to access a SharePoint 2010 site remotely, each time I went…

SharePoint 2007 ‘Task’ Managed Properties not appearing in Search Results

I am currently working on a web part which uses the SharePoint Search API and a FullTextSqlQuery to retrieve a list of the current user’s tasks rolled up across Site Collections. The web part was working great until I noticed that the Status, Start Date & Due Date were not…